Nutzen

Ein Nutzen ist eine Zusammenstellung mehrerer Platinen, welche alle in den gleichen Prozesschritten auf der selben Leiterplatte erstellt werden.

Sind genügend Platinen vorhanden kann daraus ein Nutzen erstellt werden. Der im Folgenden beschriebene Prozess ist für die Erstellung eines Nutzen für Multi-CB optimiert, kann aber auch für andere Hersteller angewandt werden.

Die Erstellung des Nutzens ist auf zwei Wegen möglich:

  • als GERBER-File über externe Software (siehe 1.2)
    • immenser Zeitgewinn (Dauer: ca 1/2h)
    • Prozess weniger fehleranfällig
  • als brd-File in eagle direkt (siehe 1.3)
    • Vorteile:
      • Unstimmigkeiten in den Ausgangsdateien können schneller erkannt werden
      • keine weitere Software notwendig
      • eagle ist als Software stabil

Statt eagle kann auch auf folgende Software zurückgegriffen werden:

  1. GerberTools von ThisIsNotRocketScience
  2. Gerbv Gerverviewer (empfohlen u.a. von Multi-CB)

Ersteres rar-File sollte in einen Basis-Ordner entpackt werden. Von letzterem Paket ist nur …\Panelizer\GerberPanelizer.exe relevant.

Limitierungen:

  • Unklar, ob auch für Platinen mit mehr als 2 Lagen nutzbar

  1. überprüfen, ob die Datei „eagle_Link.txt“ auf die gewünschte eagle.exe zeigt und ggf. korrigieren.
  2. kopieren der brd-Dateien in den Ordner „BRD“
  3. ausführen der Batch-Datei „Convert_BRD_to_GERBER.bat“

  1. Öffnen des GerberPanelizer.exe
    wichtig: GerberPanelizer.exe ist gelegentlich sehr instabil - vor allem, wenn Optionen und Funktionen jenseits der untengenannten genutzt werden.
  2. Erstellen eines Panels: File » New
  3. Import aller Ordner per Drag-and-Drop:
    im Explorer alle Ordner markieren und im neu angelegten Panel im Panelizer fallen lassen (Achtung: es müssen sich hierbei um „umgewandelte brd“-Files handeln wie in 1.1.1 vorgegeben. per CAM exportierte Gerber-Dateien werden nicht richtig eingelesen)
  4. nun sollten zu jeder Platine ein Rahmen sichtbar sein; diese liegen aber aufeinander.
  5. Falls von einer Platine mehrere Versionen benötigt werden, so können diese in der Projektübersicht rechts mit Rechtsklick auf die gewünschte Platine und „Add Instance“ eingefügt werden
  6. Eingabe der Abstände zwischen den Platinen: Panel Properties » Margin between boards
    Bei Multi-CB sollten diese 2mm betragen
  7. optimal auf dem Panel verteilen und kleinste Panelgröße ermitteln
    1. Auf dem Panel verteilen: Board Placement » Autopack: Naive
    2. Falls Platinen außerhalb des Panels oder übereinander gezeichnet werden, so ist das Board noch zu klein. In diesem Falle sollte die Panel-Größe angepasst werden: Panel Properties
    3. Die Ansicht sollte immer nachgeführt werden, um keine Platine außerhalb des Panels zu vergessen: View » Scale 1:1
    4. Die letzten beiden Schritte sind solange zu wiederholen, bis eine kompakte Panelgröße vorliegt, welche gerade alle Platinen beherbergt
    5. Die minimale Größe (Breite x Länge) sollte gemerkt werden
  8. Theoretisch könnten nun Brücken (= Breaktabs, Mousebites) zur Stabilität gesetzt werden. Bei Multi-CB ist dies nicht nötig. Diese werden ansonsten kostenlos durch Multi-CB eingefügt.
  9. Erstellen der fertigen Gerber-Datei für den gesamten Nutzen: File » Export Merged Gerbers » Ordner auswählen
    Die Erstellung kann bis zu 1..2 Minuten dauern
  1. Für Front und Rückseite sollten nun im angegebenen Ordner *.png's angelegt worden sein.
    Diese ermöglichen eine erste Überprüfung des Ergebnisses.
  2. Die Files sollten mit GerbV visuell überprüft werden.
    1. Öffnen der Files in GerbV: File » Open layer(s)… --> Suchen des Ausgabeordners und auswählen aller Dateien
    2. Überprüfen auf verschobene Vias und Pads
  3. Ist alles ok, so sollten alle Ausgabe-Dateien (nur die „merged Gerbers“) in ein einziges rar-Archiv eingefügt werden.
  4. Für den nächsten Schritt, die Bestellung, muss die Nutzengröße noch korrigiert werden. Die ermittelte Größe muss den umlaufenden Rand berücksichtigen. Bei Multi-CB wäre dies 2x 5…10mm, also etwa 15…20mm
  1. Im Control Panel: Datei » Neu » Board (oder Alt + DNB)
  2. Im neuen Board: Datei » Speichern (oder Strg + S), Speicherort: Remine » „…\Leiterplatten-Fertigung\Nutzen“, Empfehlung für den Dateinamen: MEXLEnutz_0nnn_20yy-mm-dd, mit nnn hochgezählter Wert
  3. Grid für mm aktivieren (gr mm on)
  4. Für Platine mit mehr als 2 Lagen:
    1. Die Schichtnummerierung und -anordnung muss mit den Platinen übereinstimmen. (Für 4lagig i.d.R.: (1+2*3+16) )
    2. Die Schicht- und Kupfer-Dicke muss eingestellt werden (DRC -> Layers -> Für 4lagig: Cu: 0.035mm, Pre: 0.36mm, Cu: 0.035mm, Core: 0.71mm, Cu: 0.035mm, Pre: 0.36mm, Cu: 0.035mm).
  1. gewünschtes Board (in neuem eagle) öffnen
  2. Panelisierung durchführen: run panelize » execute
  3. alle Layer einblenden (dis all)
  4. Alles auswählen (Strg + A, Strg + C)
  1. Einfügen der Platine. Beachten Sie, dass die Platine vom Rand etwa 5…10 mm (200…400 mil, 4…8 Kästchen) entfernt liegen muss. Die Abstände zu anderen Platinen sollte wenigstens 5…10 mm (200…400 mil, 4…8 Kästchen) betragen. Nutzen Sie Alt + Mauszeiger für eine genauere Positionierung. (Zahlenwerte von Multi CB)
  2. zur leichteren Positionierung sollten alle ge-lock-ten Objekte gelöst werden: dis all » Strg + A » Lock Icon klicken » Strg + Umschalt + rechts-Klick auf eines der Objekte. Nun können die Objekte leicht verschoben werden.
  3. Wichtig: Bei 4- oder mehr lagigen Platinen muss überprüft werden, ob alle Lagen übernommen wurden. Für mehrlagige Platinen müssen diese im DRC angelegt werden.
  4. Bereiten Sie die weiteren Boards - wie oben dargestellt - vor und fügen Sie diese an.
  5. Kommt es zu einer Warnung auf Basis einer unpassenden Netzklasse, so kann die abgelehnt werden (Druck auf „Nein“)
  6. Ausrichten der Boards mit den Mindestabständen wie beschrieben.
  7. Wechseln auf den Layer „Dimension“ (ch lay 20)
  8. Wire mit geradliniger Verlegung auswählen (wire , se w 0)
  9. ausgehend vom Ursprung soll ein geeignet großes Rechteck umrandet werden. Falls die Größe nicht passt, kann diese nachträglich geändert werden.
  10. Zwischenspeichern
  11. Ratsnest + DRC:
    1. WICHTIG: DRC von Multi-CB muss verwendet werden, da sonst ein Produktionsstopp droht.
    2. Vorhandene Airwires müssen korrigiert werden. Falls Vias mit benachbarten Verbindungen zusammenstoßen idt der falsche DRC gewählt. Dimensions, Drill Distance und Keepout können ignoriert werden.
  12. Überprüfen der Masseflächen: Inseln gewünscht?
  13. nur die Layers 25 (tNames) und 125 (_tnames) anzeigen (dis none 25 125).
  14. Überprüfen, ob alle Namen aus Layer 25 auch auf Layer 125 erscheinen. (dis none 25). Falls nicht, gab es einen Fehler beim Panelize und dieses muss nochmals durchgeführt werden (s.o.). Falls es auf Layer 25 außer Komponentennamen anderer Text erscheint, sollte dieser auf Layer 21 tPlace verschoben werden (ch lay 21).
  15. Allen Text auf Layer 25 löschen (dis none 25, Strg + A, Del)
  16. Text von Layer 125 auf Layer 25 verschieben (ch lay 25)
  17. Die Schritte 8. bis 11. für die Rückseite durchführen: bNames (Layer 26), _bNames (Layer 126), bPlace (Layer 22).
  18. nur die wichtigen Layer anzeigen, also Layer 1..26 und 47 (dis none 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 47)
  19. Größe des Nutzens anpassen (Linien ziehen) und Dimensionen für das Board einfügen
  20. farbiger Ausdruck zur Begutachtung und Ablage
  21. Abspeichern
  1. bei Multi-CB mit EST Account anmelden
  2. Auswahl „Leiterplatte“
  3. Bezeichnung nach Dateinamen (s.o.)
  4. Lieferformat: i.d.R. Nutzen. Bei vielen, gleichen Einzelstücken (z.B. MEXLE-Microcontroller-Platinen) kann Einzelstücke günstiger sein
  5. Größe: nach Abmaße auf ausgedruckter Zeichnung
  6. Nutzen Typ: i.d.R. Multinutzen. Vielfachnutzen nur bei gleichen Platinen
  7. Nutzenbearbeitung: Gefräßt mit Brücken oder geritzt
  8. Anzahl/Stückzahl: Bei den Nutzen i.d.R. 1, bei Einzelstücken die Anzahl der gewünschten Boards.
  9. Verschiedene Layouts pro Nutzen und Einzelstücke pro Nutzen ausfüllen
  10. Positionsdruck: doppelseitig
  11. Berechnen drücken, Auswahl der Anzahl über Klick auf den entsprechenden Preis oder über Eingabefeld „Anzahl“
  12. in den Warenkorb legen
  13. Falls keine weiteren Nutzen angelegt werden sollen, kann der Warenkorb geöffnet werden und die passende Datei angehängt werden.
  14. Nach Klick auf „Bestellung fortführen“ ist die Bestellnummer anzugeben: z.B. FiSpo_KontoNr_20yy-mm-dd
  15. Als Versandart ist UPS Standard zu wählen
  16. Von der Bestellseite ist für die Verwaltung ein PDF-Ausdruck zu erstellen.
  17. Nach Absenden der Bestellung wird zunächst auf Vollständigkeit und Herstellbarkeit geprüft. Falls dies nicht der Fall ist meldet sich MultiCB nochmals. Wenn alles passt, wird die Produktion automatisch ausgeführt.